Installation

The easiest way to install Lentil is with pip:

pip install lentil

Python version support

Lentil requires Python 3.6 and above

Dependencies

Package

Minimum supported version

NumPy

1.16

SciPy

1.4

Installing from source

See the contributing guide for instructions on installing from the source code.

Running the test suite

Lentil comes with a suite of units tests. See running the tests for instructions on running the tests.